Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    Hello, I can't open one of my Ulysses 2.0 projects.

    I get this error message:


    Error during opening

    error during opening (not all) data could be read properly.
    Automatic project saving has been disabled until next manual save.


    Has anybody else gotten this message?

    Hey I got my project back!

    Automatic backups are the bomb!
    • CommentTimeApr 10th 2010

    The problem probably was some corrupted file in your project. Not sure wich it was, but most of these origin from a corrupted index. Restoring a backup is durely the easiest way to fix it. Glad it helped for you.

    • CommentTimeJul 19th 2010
    I receive this error almost everytime I try to open a project. Several different files, restored from backup, made brand new ones, still the same issue. My company is looking for a courseware development replacement and we would like to use Ulysses, but I'm holding the order because of this issue, which seems to have no resolution.
    • CommentTimeJul 19th 2010

    These issues definitely have a solution. It would be great if you contacted us via email at so that we could go through this issue with you and find a solution. The error actually appears only when the project file has been corrupted and something cannot be found -- so this should not be the normal case.

    • CommentTimeJul 20th 2010
    This only "sort of" relates to this thread.

    This reminds me of a situation where I hadn't saved a project on my hard drive (as in: not saved at all), but had had Ulysses open with that project for almost a week. At some point, Ulysses freezed (for whatever reason, I don't remember), I force-quit because I had forgotten that I was working with an unsaved project ... well, I lost my whole text, because, of course, there are no backups for unsaved projects.

    Actually, Ulysses had even tried to create a backup for my project (at least there was something with the name "unsaved" in the backup folder), but that got corrupted when I was force-quitting... (that's the "sort of" connection to this thread).

    While all of this was certainly my fault (who works with an unsaved project for a week???), I still thought that it might be worthwhile to make Ulysses behaviour a bit more fool-proof for such cases, i.e. somehow encourage people not to work with unsaved stuff (there is a small note now at the lower right side of the screen, but a *very* unobtrusive one).
    • CommentTimeAug 31st 2010
    Even though sometimes I get this opening a project it still opens as an unsaved "new" project with all the data still there. I then have to Save As... and rename it for it to work again.

    Most recently a file in the project was corrupt, I guess, meaning that when I clicked on that docs tab in the window Ulysses would freeze and I would force quit. Finally I chose "Show Package Contents" on the Ulysses file, found the folder with the offending file and removed it manually from the filename.ulys file. Upon opening it gave me the same error as above, I did as I outlined above, and now it works fine. Strange.
    • CommentTimeSep 10th 2010

    This error message is printed whenever something could not have been loaded as expected. So for example if a document that is supposed to be there is actually gone, Ulysses will show the error. While this is nice, it's not really helpful. And you have to not just click this message away. Thus, we will change this in the next version:

    • When a problem after saving occurs, a backup of the broken project will be created
    • the actual project will be repaired and you continue to work on it as usual
    • the error panel provides additional information on what went wrong.