Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorvze26m98
    • CommentTimeJan 11th 2011
     
    On the LaTeX export page under "Conversions->Convert Characters," I've got the character "%" to be replaced by "\%".

    When I run the export Ulysses stalls, makes my fan run, and I eventually have to force quit after several minutes. I first encountered this on a bigger document of mine, but testing on a 153 character scratch document with just one "%" character in it, I get the same behavior.

    Am I misunderstanding what "Character Conversions" is supposed to do? I simply want to escape the two places that "%" appears in my working document. I know I can type this in, but thought that this feature would do the conversion for me.

    Best wishes and Happy New Year,

    Charles
    •  
      CommentAuthormichael
    • CommentTimeJan 11th 2011
     
    This is a bug in the current version of the LaTeX exporter. The problem is, that the string "\%" contains the chracter to be replaced. This is fixed in the coming Ulysses 2.0.5. As a workaround you can convert the character in two steps. First convert it to any temporary string and then convert the temporary string to the desired string.

    But what you really want is using the "Mask characters" option. ;)