Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthor0advena0
    • CommentTimeFeb 27th 2011
     
    Hello-
    I don't have a lot of time right now so I'm just going to get this down and hopefully someone can tell me if these issues are bugs or not.

    1) I use "text replacement" (edit>substitutions>text replacement). This setting doesn't stick at all. If i set it and switch to a different project it turns off. If i switch from console mode to regular it turns off & when starting Uls i always have to turn it on. Doesn't matter if i save or anything... it never sticks. Bug or ???

    2) General prefs. Some stick others don't seem to. I don't know if this is project related or not, so this one may be user error, although you would expect the main app prefs to be sticky and use document/project specific prefs for variable things, but Uls does things differently in other places (crazy keyboard shortcuts etc) so it may be normal behavior.

    3) Some of my shortcuts aren't working or work sporadically. The main ones i'm referring to are the field changing ones CMD+OPT+arrow keys. Sometimes they work and other times i get a system warning beep. Doesn't seem to have any rhyme or reason.

    4) It would be nice (for me at least) for the "Title" field to be the default active area since Uls requires a pretty good organizational and naming schema...It drives me nuts to have to mouse over to that field after cmd-N (since the keyboard shortcut to switch there doesn't work regularly)... seems that setting this field as default and setting that field as a single "tab" to get you to the main text editor is the most logical way...

    5) I've noticed that Uls won't allow certain key commands to work. I haven't experimented much with this but i know for a fact it didn't work to use a 4-modifier key shortcut (ie SHFT-CTRL-OPT-CMD. FYI, i use the trackpad to trigger these long shortcuts). I had to shorten it to 3 modifiers and then it worked.

    these are the main things that i would like to figure out. I apologize if i sound terse... i love Uls but these things annoy me and i'm a bit time crunched right now.

    -scott
    •  
      CommentAuthor0advena0
    • CommentTimeMar 2nd 2011
     
    Hello? Bueller? Bueller?

    I would really appreciate some sort of help with this... Does anyone have any ideas? Devs?

    This is my second topic posting and I have yet to hear from the devs on either of them. Doesn't bode well...
    •  
      CommentAuthordirk
    • CommentTimeMar 3rd 2011
     
    I'm sorry for missing both of your topics. Don't know how I could miss them!

    1) We're already working on getting this fixed, seems to be a bug.
    2) Can you please give some examples?
    3) The cmd-opt shortcuts sometimes seem to have problems on MacBooks. We're still trying to figure out why they sometimes don't work, but sometimes do.
    4) Thank you for the suggestion, I'll add it to our list :)
    5) I must confess that I never noticed that, but now can reproduce it. We'll see what the reason behind this is.
    •  
      CommentAuthor0advena0
    • CommentTimeMar 3rd 2011
     
    2) Here are some that don't stick no matter what I do with the preference OR how I save the template file.

    "Document Defaults"
    *Title*-This doesn't stick for the INITIAL document in a new project. It seems to stick on all subsequent documents created in a project. So for example I have "new" as the title. When I create a project, the first... hmmm I just went back to make sure I was noting everything correctly and it seems to only be a single template file giving me problems. It's one I regularly use though. Other templates and "blank" work correctly so I will mess with the funky template.
    *Notes* - this doesn't stick for me. Seems to open in Notes+Excerpt even though I have it set to "Notes" and have saved my templates with "Notes" only.

    Then there are the spelling prefs that aren't working as well as the replacement etc, which you said you're aware of.

    3) I can't wait to see if this gets resolved, either on your end or Apples... not having trustworthy KB commands isn't good :(

    4) Thanks!

    5) Sounds good. Yeah I usually use crazy shortcuts so I don't get conflictions... they then get trigged with BTT or controllerMate etc.

    BTW, I'm finding that after creating a new document I can NEVER switch to the document title using the keyboard command... once that doc has been saved and I work a bit though it seems that I can get over there *occasionally*. Switching tabs works fine though... I am on a macbook, BTW.