Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorvze26m98
    • CommentTimeJun 6th 2011
     
    Hi all-

    Moved Ulysses to a new computer: copied across the preferences, and stuff in Application Support. My documents came up in Lucida Grande instead of my previously specified default of Deja Vu Sans Mono.

    I went to preferences and fixed this for the Editor window, but for Notes, even though preferences say it's set on Deja Vu, the content window is still stuck on Lucida.

    Any thoughts on how to resolve this?

    Best, Charles
    •  
      CommentAuthordirk
    • CommentTimeJun 6th 2011
     
    Hi Charles,
    as the Notes are Rich Text, the Fonts&Colors settings are only for new text in the Notes, existing text will not be changed. I don't really know why the fonts were changed in the first place, but you can change them back by selecting the text in the Notes and choosing a font via Format > Font > Show Fonts.
    •  
      CommentAuthorvze26m98
    • CommentTimeJun 8th 2011
     
    Thanks, Dirk-

    Tentatively, I might suggest that this is the problem: Ulysses encodes the RTF font specification as this:

    {\fonttbl\f0\fnil\fcharset0 BitstreamVeraSansMono-Roman;}

    While TextEdit encodes it like so:

    {\fonttbl\f0\fnil\fcharset0 DejaVuSansMono;}

    (BTW, Deja Vu Sans' plain face is "Book," not "Roman.")

    So, if I open up a Notes "TXT.rtf" file in TextEdit, it can't read the font spec and defaults to Helvetica. This doesn't explain why Ulysses can read the font spec satisfactorily from launch-to-launch, but then can't on a new install. But maybe someplace to look for a fix.

    Best wishes, Charles