Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthoridmah
    • CommentTimeSep 19th 2011
     
    One asterisk symbol * is ok, but ** is an underline ?

    *vgh <- normal
    **vgh <--- this is underlined.

    Bug ?

    or

    Feature ! hahhaaaa!

    Doesn't show up in full screen mode tho.

    Fixed in new update?
    thanks
    Ian
    •  
      CommentAuthorniklas
    • CommentTimeSep 19th 2011 edited
     
    Hmm.

    Not *quite* sure I understand what you mean ... but,

    could it be that you have the two asterisks set up as a tag to mark the beginning of an inline style, and that this style is set up to display in italics in the editor?
    •  
      CommentAuthoridmah
    • CommentTimeSep 19th 2011 edited
     
    Don't even know how to set up tag. so probably not.

    Do you mean inline styles .. which is set to ** Strong
    but would this appear as an underlined "**" in console Mode?

    I'm a big line of asterisks "**********" person so this is frustrating..

    thanks
    Ian
    •  
      CommentAuthordirk
    • CommentTimeSep 19th 2011
     
    You can check Ulysses > Fonts & Colors > Standard Mode or Console Mode to see if you have set the appearance of any of your Styles to underlined.
    •  
      CommentAuthorniklas
    • CommentTimeSep 19th 2011
     
    > You can check Ulysses > Fonts & Colors > Standard Mode or Console Mode to see if you have set the appearance of any of your Styles to underlined.

    ... and, I might add, if you are a big line of asterisks person you can change the double asterisks to anything you like in Ulysses > Preferences > Inline Styles. Use something you don't normally type.
    •  
      CommentAuthoridmah
    • CommentTimeSep 20th 2011
     
    I looked in there..

    Yeap ** is marked as strong. Set by default. as underline..

    Can I change this (define another style for underline [strong])?
    I did turned it off by selecting Use Style from Console mode? but work around verse a solution..

    thanks
    Ian
    •  
      CommentAuthorniklas
    • CommentTimeSep 20th 2011 edited
     
    It almost sounds as if you still think this is a bug or something. It is not a question of finding a workaround, this is how styles work in Ulysses and I really recommend that you take some time to learn how to use them. Look in the documentation, or have a look at one of the screen casts on the soulmen's website on "semantic editing". It'll be well spent time.

    The default styles are just suggestions, to show you how they can be used. You can change them as you like, or remove them altogether. If you still want a style for "strong" for example, you can go to the Inline Styles panel in the preferences, double-click on the asterisks, and change the tag to something else. It is really easy!
    In the Fonts & Colors prefs that dirk mentioned you can then tell Ulysses how you want this style to show up in the editor (and in the exporter you tell it how it should look when exported).

    You spend some time setting things up as you like it, and then you can forget about it!