Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorCeejames
    • CommentTimeJan 29th 2012
     
    Trying to export ePub from Daedalus to Creative Book builder, but it gacks on the file, returns an error

    Toc.ncx does not exist

    I would really like to use Daedalus as primary editor and then use CCB to tweak it for final output, as it is a more robust ePub focused editor, but at moment cannot get it to import anything from Daedalus, am adressing it with them as well in case it is something in there side.

    By the way great app, makes typing on iPad so much easier, now if Apple could just get the split keyboard to not slide up the screen and hide the text I type would be nearly perfect.
    •  
      CommentAuthorgoetz
    • CommentTimeJan 30th 2012 edited
     

    We're glad that you like Daedalus Touch! :) About the ncx issue: it seems to me that the problem lies on Creative Book builder's side. Our ePub files include an ncx file (you can see it if you rename it to a zip file and unzip it). However, it is named book.ncx (the ePub specification only mentions the extension, not the actual file name, so we don't violate the spec). We can change the name of the file to toc.ncx since this seems to be a common name of the ncx file.

    In the meantime, you can use the following workaround (it's a bit tedious, sorry):

    1. Move the ePub file to your Mac (e.g., by e-mailing it to you). Rename it to a zip file, and open it using a zip application, like Springy.
    2. In the subfolder OPS, you can find the file book.ncx. Rename it to toc.ncx.
    3. In the same folder, open book.opf using a text editor, and change the mention of book.ncx to toc.ncx (should be in line 14).
    4. Close the zip file and change to extension back to epub.

    I haven't had the chance to try it out myself since it don't have the Creative Book builder, but it should work.

    Götz

    •  
      CommentAuthorCeejames
    • CommentTimeFeb 2nd 2012
     
    Seems to be other issues, tried the above and still came up with error. Then tried moving files and gave new error

    content.opf does not exist

    At this point not sure what is causing incompatibility, will be emailing their tech support. Since anything I have created so far in DT, has been readable in iBooks, which is my benchmark.
    •  
      CommentAuthorgoetz
    • CommentTimeFeb 4th 2012
     
    Strange. I'm positive the error is on the side of the Creative Book builder, since our generated ePubs adhere to the spec and can be opened in iBooks and other ePub viewers flawlessly. You can also contact us directly at support@the-soulmen.com so we can sort out this issue in detail.