Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthornachoE
    • CommentTimeApr 20th 2012
     
    When I select text in Ulysses, copy it and paste it on other part of the document Ulysses adds a space before and after the selection.

    Is there a way to remove this behaviour? It's annoying me a lot, and I don't see a way of changing it.
    •  
      CommentAuthorgoetz
    • CommentTimeApr 20th 2012
     
    I think the option you're looking for is "Smart Copy/Paste". Open up the Preferences (Cmd-,), go to Standard Mode, and disable Smart Copy/Paste. It's actually one of OS X's system text features.
    •  
      CommentAuthornachoE
    • CommentTimeApr 20th 2012
     
    Thank you very much, this fixed my problem, and you answered really quickly. I didn't know what this smart copy/paste was, now I know I'm smarter than it so better disable it.
    •  
      CommentAuthorsmolk
    • CommentTimeApr 3rd 2013
     
    However, disabling Smart Copy/Paste does not work for the Notes where the spaces are added regardless of the preference setting
    •  
      CommentAuthorgoetz
    • CommentTimeApr 3rd 2013
     

    True. However, you can enable Smart Copy/Paste for the current Note by selecting that Note and enabling "Smart Copy/Paste" in Edit > Substitutions. Works only for the current Note though..