Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorjb
    • CommentTimeApr 22nd 2012
     
    I just put Daedalus on my ipad. And of course it is great, as I expected. I really like the configurable keyboard extension and the tap to move cursor.
    Thank you.


    Daedalus syncs almost perfectly for me via Dropbox (as .txt), but I have one odd problem.


    Every sheet, once it becomes a file, has odd text at beginning (after title):

    {%$]----------


    It doesn’t show up in Daedalus itself, but it does show up in the .txt file on my Mac.

    I’ve seen elsewhere someone had the same problem. So I’m wondering if there’s a fix.
    •  
      CommentAuthorgoetz
    • CommentTimeApr 22nd 2012
     

    Glad you like Daedalus :)

    Daedalus needs to store the title of a sheet somewhere. Usually it is stored as part of the filename. However, whenever the title contains symbols that cannot be used in file names when syncing, those symbols need to be replaced in the file name and the title needs to be moved into the file itself. To clearly separate the title (which may span multiple lines) from the document, the separator is inserted in between.
    There is not much we can do about this, unfortunately. However, if you don't use special characters in titles, this problem should not occur.

    •  
      CommentAuthorjb
    • CommentTimeApr 22nd 2012
     
    Thanks, goetz.

    In my case, it turns out that it's the Daedalus setting to preserve ordering in Dropbox that makes the trouble. This is buried in the Dropbox settings. If I turn that off, the number and the hyphen that goes with it disappear and so does the {%$]----------

    Thanks for explaining. It made it possible for me to figure out, since I wasn't using any odd symbols in the titles. It was Daedalus who was inserting them! Now I see what's going on and how to get around it.

    I'd like to be able to preserve ordering AND avoid the {%$]----------, though. Maybe you guys can figure out how to do that?

    Cheers
    •  
      CommentAuthorkhop
    • CommentTimeApr 22nd 2012
     
    It has something to do with the difference between UTF-8 and UTF-16? If DT sends it as UTF-8, be sure to set the receiving app also in UTF-8. Problem done, at least that's my experience.
    •  
      CommentAuthorjb
    • CommentTimeApr 22nd 2012
     
    Hi khop,
    Do you mean to say that you’ve had the same problem and solved it by changing the encoding?

    I’ve opened in TextWrangler with every encoding I can find and there’s no change.

    With UTF-8 the problem remains. In fact, I think every app I have uses that as the default.

    I assume Daedalus uses UTF-8.

    But if you can enlighten me any further, please do ;-)
    •  
      CommentAuthorgoetz
    • CommentTimeApr 25th 2012
     

    I'd like to be able to preserve ordering AND avoid the {%$]----------, though. Maybe you guys can figure out how to do that?

    Currently, this is not possible. When ordering is preserved, the index of the document is added at the start of the filename (e.g., 1 - My first sheet). Thus, the title needs to be saved inside the file. We're looking at options how to achieve both things (preserve ordering, no title in file) at once.