Not signed in (Sign In)

Vanilla 1.1.9 is a product of Lussumo. More Information: Documentation, Community Support.


    This is sort of an emergency. I've been writing a second-year medical school essay piece in Ulysses III (I converted it over from Scrivener on release). It was all going fine, and I loved the way Ulysses III worked. However, now all it does is crash on startup. There is no obvious reason for this, as far as I can see, as it was working well last night.

    Due to the iCloud storage, I don't see a way I can access the files for work in another app. This is a major issue, because the deadline for the project is tomorrow!!

    Can you guys help me at all?
    Okay, I've got to admit I panicked a little bit there.

    I had a look at the bug report and fortunately, due to a bit of experience in programming, I managed to make some sense of it. I run a Macbook Pro Retina 15inch, but I often use it with 1, 2 or 3 external display(s) in closed clamshell mode (some would say this is a crime, I know!).

    The bug report suggested there was a UI rendering error (i.e. no problem with iCloud storage etc). At the time of initially opening the app, I was running one external display. This made the app crash.

    I felt it would be worth a shot to try and put my display setup back to what it was when I closed the app after working last night (2 external display setup). This made the app work again.

    Now, when I switch back to a 1 display setup, then close the app, then plugin the other display and try to open the app again, it crashes. This suggests that either Ulysses, Apple development framework or OSX saves the display state of the computer on closing (I can definitely see a practical purpose for this), but Ulysses does not correctly handle starting up if the display setup changes between closing the app and starting it up again.

    Hopefully this will be helpful to the developers!
    • CommentTimeApr 9th 2013 edited


    we're really sorry that you're having trouble with Ulysses.

    Can you please try the following?
    - Open the "Terminal" application, either through Spotlight or in Finder > Applications > Utilities. - Type the following line and hit return

    defaults delete com.soulmen.ulysses3 ULWindowController_defaultInterfaceState

    This commands resets the saved application state of Ulysses. Does this fix your problem?

    Sorry for the hassle